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Fumis PC-PRO is a computer based application that provides access to FUMIS® controllers. It enables you to configure and 

maintain heating systems with Fumis controllers. Fumis PC-PRO significantly reduces time and cost of installation setup, and 

simplifies heating system maintenance. 

Fumis PC-PRO application is intended for manufacturers, installers and service personnel for setting up and configuring the heating 

systems controlled by the Fumis controllers, optimizing the performance, and maintaining the heating systems. 

Fumis PC-PRO connects to the FUMIS controller directly, using the uCOM converter cable. 

 

Fumis PC-PRO runs on Windows platform. Minimum system requirements are: 

 800 MHz processor 

 512 MB RAM 

 100 MB available disk space 

 

To connect the computer to the Fumis controller, you need the uCOM converter and an USB cable (available separately at ATech). 

 

In addition, the FTDI device drivers are required: 

 Virtual COM Port (VCP) driver 

 Direct (D2XX) driver 

The VCP driver emulates a standard PC serial port such that the USB device can be communicated with as a standards RS232 

device. The D2XX driver allows direct access to a USB device via a DLL interface. 

Both drivers are included in the installation pack. 

 

 

 

 

The Fumis PC-PRO installation file is located on the CD. To install the Fumis PC-PRO application, run the  

Fumis_PC-PRO_setup.exe file and follow the wizard. 

 

When you successfully finish the installation, connect the computer to the controller using the uCOM converter and an USB cable. 

You are prompted to install the FTDI device drivers. The drivers are located in the Fumis PC-PRO installation folder (typically in 

folder C:/FumisPcPro/Drivers/FTDI_Driver/CDM_20600). In the Found New Hardware Wizard select the option Install from a list or 

specific location and then supply the location of the drivers. Follow the wizard to complete the installation. 

 

TIP:  

To avoid unnecessary problems, we recommend you to first connect the hardware, and then run the installation.  

 

To start the Fumis PC-PRO application, go to Start/Programs/Fumis PcPro and click Fumis PcPro. At first startup of the Fumis PC-

PRO application you are prompted to configure passwords for three different user groups, Production, Servis, and Development. At 

the moment the permissions for these user groups are not defined. 
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With the Fumis PC-PRO application you can configure and manage Fumis controllers. First connect the computer to the controller. 

To start the application, go to Start/Programs/Fumis PcPro and click Fumis PcPro. The Fumis PC-PRO opens the Telemetry window. 

 

To access the Fumis controller, first import the map 

file for the selected Fumis controller (for example, 

Fumis ALPHA). The map file, provided by ATech, 

contains information for the specific controller type.  

To import the map file in the File menu click Import 

MAP File. Locate the required *.map file (for 

example, FumisAlpha.map), and click Open. 

 

Then set up the connection to the Fumis controller. 

In the Setup menu click Communication. Select 

the COM Port, through which you connected to the 

controller, and in the Boud Rate field select 38400. 

Click Open Port and then click OK.  

 

The application stores the COM Port setting and 

connects to this port in all future sessions. In case 

another application connects to the same port, they 

are in conflict. In this case close the second 

application to release the required COM Port. 

 

CAUTION:  

The Telemetry window is used for direct access to the Fumis controller and enables monitoring and controlling the operation of the 

Fumis controller. Use the options in this window carefully, as any mistake can result in serious damage to the controller. 

 

 

To manage the Fumis controller, in the Tools menu click Control Panel. This opens the Control Panel window, where you can 

monitor, manage and configure the controller.  

 

To test the operation of the controller and the connection, click Sync Time button in the Control Panel window. If MB Time and 

PC Time values synchronize, the controller is up and running, and the connection to the controller is established properly. 

 

In the Control Panel window you can monitor the 

performance of the heating system with the Fumis 

controller. The left pane contains the list of all 

parameters for the controller. Note that the disabled 

parameters are crossed out and cannot be modified. 

 

The parameter values can be saved to a *.prm file. 

You can use this file to import or export parameter 

value settings.  

To export parameter settings, in the File menu click 

Save Parameters. 

To import parameter settings, in the File menu click 

Load Parameters. Locate the required *.prm file 

and click Open. 

 

To modify the parameters, select the required 

parameter and change the parameter setting value. 

For each parameter a valid value range is defined and 

you cannot set the value outside the valid range. To 

save the setting press Enter or click Write, 

otherwise the change is discarded when you move to a different parameter field. 



www.atech.si  - 3 - 

To configure the Fumis controller, first select one of the predefined configurations or define a custom configuration, and then set a 

valid value range for the required parameters. 

 

To select the configuration, in the Tools menu click Configurations. This opens the Configurations 

Setup window. In the Config No. field select the predefined configuration.  

 

To define a custom configuration, you can use a predefined configuration as a template. Click Use as 

Template and modify the required options. When you are done, click Set Custom to save the 

custom configuration to the list of configurations. 

 

To save the selected configuration for the controller, click Set Current Operating Mode and close 

the window. 

 

 

 

To set a valid value range for the parameter settings, in the Tools menu click Parameter 

Limits.  

 

The parameter limits can be saved to a *.prl file. You can use this file to import or export 

parameter value range settings.  

To export parameter value range settings, in the File menu click Save Parameters Limits. 

To import parameter value range settings, in the File menu click Load Parameters Limits. 

Locate the required *.prl file and click Open. 

 

To set the parameter limits, select the required parameter and enter the minimum and 

maximum values in the appropriate fields. You can select the values between 0 and 255. To 

disable a parameter, enter the 0 – 0 Min and Max values. 

 

To save the settings press Enter or click Write, otherwise the change is discarded when you 

move to a different parameter field. 

 

 

 

 

 

The Fumis PC-PRO application enables you to test the performance of the heating system. With the Sequencer tool you can 

automate the testing procedure. You can provide a file containing a set of instructions to be performed on the system, and the 

results are logged. 

 

To set up the automated testing procedure, first edit the provided test template file in Excel. In the table specify the instructions as 

necessary and then save the file as a tab delimited text file. Note that you can also edit the text file directly, but make sure to use 

the Tab delimiters correctly. 

 

To import the tab delimited text file, in the Tools menu 

click Sequencer. This opens the Sequencer window. In 

the File menu click Open Sequence File. Locate the 

required *.txt file (for example, FumisAlphaTest.txt), and 

click Open.  

 

The settings are imported in the Sequencer table as 

read-only. In case any of the settings are outside the 

valid value range, you are notified and the setting is 

automatically modified to the maximum permitted value. 

 

If you want to cycle the procedure, check the Enable 

RollOver option. To start the testing, click Sequence Start. 

 

NOTE: 

The automated testing procedure stops when you close the Sequencer window. If you intend to run the test for a longer period of 

time, make sure to disable the power saving options in Windows. 
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LEGAL NOTICE: Fumis products are intended for controlling the process of biomass combustion in wood 

biomass heating systems (pellets, cutter chips, firewood) and wood-like biomass (pallets and briquettes 

from another biomass, shells, vegetable grains and the like). Functioning of these devices can, in certain 

circumstances, among other, produce next risks: 

A.) When the device is not used appropriately, an excess amount of explosive mixture of wood gas and air 

can be produced in the device which may explode 

B.) In case of misuse and excessive overheating of the device the pressure inside the boiler can become too 

high and the boiler can explode 

C.) During the combustion carbon monoxide is being produced, inside the device. In case of inappropriate 

exhaust design or operation, carbon monoxide can threaten health and life of people and animals 

Abovementioned explosions are powerful enough to produce the damage on combustion device, nearby 

devices and also on the building where the device is installed. People nearby can be injured 

To avoid abovementioned risks it is necessary, when setting or changing parameters of device operation, to 

use Fumis PC-PRO software with a special care, so the operation parameters of the Fumis product stays at 

all times within such limits, to ensure safe operation of the whole device, in accounting for the operating 

principles of the Fumis product, characteristics of the device containing the Fumis product, required safety 

devices, and also circumstances in which the device is being used. Any person setting up or changing the 

Fumis product settings, with acceptance of these conditions of using Fumis PC-PRO software, expressly 

declares and guarantees to be fully acquainted with operating principles of the Fumis device, the product 

containing the Fumis device and with circumstances in which the device is being used, as well as with the 

meaning and effect of changing the particular operation parameters of the Fumis device, and also accepts 

full responsibility for all damage that may occur as a result of inappropriate setting of the Fumis product, 

with regard to characteristics of the Fumis product, characteristics of device in which the Fumis product is 

installed, or circumstances in which the device is being used. 

The Fumis PC-PRO application enables you to monitor the operation of the Fumis controller. You can view and analyze the Fumis 

controller output data. You can also collect and store the data to a log file. 

 

To monitor the operation of the Fumis controller and collect the log files, in the Telemetry window first select the variables you 

want to view, and then configure data logging. 

 

To view the output data for Fumis controller, in the Telemetry 

window select the variables in the Variable Selection drop-down 

list. Specify other options as required and click Add To List. The 

selected variables are loaded into the list, and you can view the 

detailed properties of the variables. 

To display the graphical representation of the variable 

performance, select the variable in the list, specify the graph 

options as required and click Draw. 

 

For the variables in the list you can collect the log file. To enable 

data logging, in the Data Logger window section click Configure. 

This opens the Data Logger Configuration dialog box. 

 

In the Log Save Tick field select the frequency for saving the 

output values (for example, to save the values to the log file each 

second, in the field enter the value 10). Click Set Log File and 

select the filename and location for the log file. Then click OK to 

close the dialog box. 

 

To start logging the data, check the Enable Data Logging 

check-box. The log indicator blinks each time the log file is saved. 

To stop logging, uncheck the Enable Data Logging check-box. 

 

Fumis PC-PRO offers additional tools for managing the Fumis controllers. These can be accessed in the Parameters window in the 

Tools menu. The provided tools are: 

 Timers – tool for setting the weekly timer programs. To import the timer settings from the Fumis controller and 

display them in Fumis PC-PRO, click the READ button. To load the timer settings to the Fumis controller from 

Fumis PC-PRO, click the WRITE button. 

 BootLoader – tool for updating the Fumis controller firmware pack 

 Diagnostic – tool for digitally testing the outputs 

 Status Log – tool for viewing the last 16 log events (events and errors) 

 

IMPORTANT: 

All external files, required by the Fumis PC-PRO application, are provided in the <install_dir>/Files folder (for example, 

C:/FumisPcPro/Files). Additional help and user guides are located in the <install_dir>/Manuals folder (for example, 

C:/FumisPcPro/Manuals). 
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